Issue Processing Payments
Incident Report for RoomKeyPMS
Resolved
At 10:06 AM PST on Thursday, January 25, 2024, reports emerged regarding challenges faced by customers in processing credit card transactions through RoomKeyPMS Payments.

Our Product & Development team promptly launched an investigation and identified that Microsoft Azure experienced degradation in one of its components. Subsequently, our team implemented a change with additional backup measures to our technical infrastructure to prevent such incidents from recurring. As a result, transaction processing improved by 2:47 PM PST.

We sincerely apologize for any inconvenience caused and appreciate your understanding. A comprehensive investigation is currently in progress to gather further details about the incident.
Posted Jan 25, 2024 - 10:00 PST