API & EDH Issues Identified

Incident Report for RoomKeyPMS

Resolved

Resolved – API & EDH Service Disruption
Timeframe: October 21, 2025, from 9:00 PM to 12:40 AM PST

The earlier issues affecting API services and the Enterprise Data Hub (EDH) have been resolved. Both services are now fully operational following the completion of the server migration.

We appreciate your patience and understanding while our team worked to restore service.
Posted Oct 22, 2025 - 08:05 PDT

Investigating

Following the recent server migration, we’ve identified issues affecting API services and the Enterprise Data Hub (EDH). Our team is investigating and working to restore normal service as quickly as possible.
Posted Oct 21, 2025 - 23:28 PDT
This incident affected: Enterprise Data Hub (EDH) (IDeaS, TravelClick GMS, TravelClick iHotelier Advanced 2-Way, Profile Match & Merge, Duetto EDH, Vertical Booking) and RoomKeyPMS Interfaces & Integrations (API).