Last week, EDH shut down after exceeding its default exception threshold. We’ve since increased this threshold and added monitoring to alert our development team if the service is down for more than 5 minutes.
EDH processes messages by querying the database for changes and loading them through the integration. A high volume of changes in a short period can cause temporary message failures, which EDH retries until successful.
On Friday, we restarted EDH following an API integration failure. Last night, a deployment misconfiguration led to a spike in API exceptions. We’ve corrected the configuration and enhanced monitoring to ensure faster recovery and greater stability.
Posted Jun 19, 2025 - 10:10 PDT
Monitoring
We are investigating an issue that occurred between last night (6/16) and early this morning (6/17), during which one of the EDH components, IntegrationAPI, failed and stopped functioning.
This interruption affected outgoing messages and impacted several services, including TravelClick, Duetto, and IDeaS. During the incident, EDH held the outgoing messages through the night.
At this time, we have not yet been able to determine the root cause of the failure. As part of our response, we have implemented additional alerts and monitoring to help detect and address similar issues more proactively and prevent this from happening again.
Everything is operating normally now, and no further action is required on your part. We appreciate your patience and will provide further updates if new information becomes available.
Posted Jun 17, 2025 - 10:52 PDT
This incident affected: Enterprise Data Hub (EDH) (IDeaS, TravelClick GMS, TravelClick iHotelier Advanced 2-Way, Duetto EDH).